نظرات ارزشمند شما:

برای ارسال نظر ابتدا باید وارد سایت شوید

  • سلام وقتتون بخیر باشه
    هنگام اجرای

    
    
    npm install node-sass

    این پیام نمایش داده می شود
    
    
    npm WARN deprecated har-validator@5.1.5: this library is no longer supported
    npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details.
    npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142

    added 240 packages, and audited 241 packages in 1m

    19 packages are looking for funding
    run `npm fund` for details

    found 0 vulnerabilities

  • سلام وقتتون بخیر
    ممکنه منم راهنمایی بفرمایید

    npm ERR! gyp ERR! find VS including the "Desktop development with C++" workload.
    
    npm ERR! gyp ERR! find VS For more information consult the documentation at:
    npm ERR! gyp ERR! find VS https://github.com/nodejs/node-gyp#on-windows
    npm ERR! gyp ERR! find VS **************************************************************
    npm ERR! gyp ERR! find VS
    npm ERR! gyp ERR! configure error
    npm ERR! gyp ERR! stack Error: Could not find any Visual Studio installation to use

    • سلام وقت بخیر.
      به احتمال زیاد مشکلی در نصب vscode بوده که نیاز هست متن ارور را، یعنی npm ERR! gyp ERR! find VS including the "Desktop development with C++" workload را سرچ کنید و راه حل های مختلف را بررسی کنید. الان شما اجرای دستورات npm که توی دوره زده میشه را توی cmd ویندوز تست کنید.

  • سلام استاد واقعا بابت سایتتون تشکر میکنم در روز پنج شش ساعت در حال دیدن مطالب سایت شما هستم
    استاد من در نصب node-sass به مشکل خورد اخه دقیقا مثل آموزش جلو میرم و پکیج تا یه جایی نصب میشه و یه پوشه ساخته میشه و بعد از یه وقفه در نصب ارور میده و پوشه هم حذف می شه

    PS G:\tamrin\fff> npm install --saveDev node-sass@4.5.3
    
    npm WARN deprecated har-validator@5.1.5: this library is no longer supported
    npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is
    known to be problematic. See https://v8.dev/blog/math-random for details.
    npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142

    • سلام وقت بخیر.
      اگه وارد داکیومنت پکیج در npm بشید. توی یک جدول مشخص کرده که با توجه به ورژن node.js که روی سیستم نصب هست،کدام ورژن node-sass را نصب کنید.
      برای مشاهده ورژن node توی cmd دستور node -v را وارد کنید.
      اگه به تازگی node را روی سیستم نصب کردید، کافیه آخرین ورژن پکیج node-sass را نصب کنید با دستور npm i node-sass

  • سلام استاد عزیز خسته نباشید ممنون از دوره ی خوبتون یه سوال برام پیش اومد برای ساخت پکیج حتما باید پوشه فایل پسوند node-sass باشه چون من پسوند پوشه رو عوض کردم ارور دارد اگر امکانش هست راهنمایی کنین .

    • سلام وقت بخیر.
      ممنون از شما
      متوجه سوالتون نشدم، پسوند پوشه نداریم!
      موارد مربوط به پکیچ node-sass را نباید تغیر بدهید

  • سلام
    ممنون که پاسخ دادین مسأله ارور نیست با اینکه ارور نشاندهنده اینه که کارا خوب پیش نرفته. وقتی ارور میده پوشه نصب نمی‌شه منظور همان پوشه‌ای که خیلی چیزها توش قرار می‌گیرند دیگه خودتون می‌دونید منظورم چیه.

    • سلام وقت بخیر.
      ببینید npm یک پکیج منیجر برای جاوااسکریپت هست و پکیج های js که شما توی پروژه دارید را نصب میکنه و توی پوشه ای به اسم node_modules برای استفاده قرار میده و ربطی به sass نداره، صرفا شما یک پکیج برای کامپایل sass میخواهید استفاده کنید.حالا چون اولین پکیج هست میاد پوشه node_modules را ایجاد میکنه و داخلش قرار میده، دوره ای npm هم توی وب سایت قرار دادیم

    • سلام وقت بخیر.
      متن ارور چیز خاصی نگقته، یکبار دیگه تصب کنید توی یک پروژه دیگه.
      داکیومنت را بخونید و چک کنید نسخه ای که نصب میکنید با نسخه node شما اوکی هست