توضیحات

در این جلسه به توضیح نصب و کانفیگ laravel passport در دوره آموزش ساخت وب سرویس با لاراول (Laravel Rest Api) پروژه محور میپردازیم.


پی اچ پی php laravel لاراول postman API وب سرویس

مدرس دوره علی شیخ
مدت دوره 10:16:14
تعداد ویدیو 59

وضعیت دوره : کامل شده
قیمت دوره : 399,000 تومان

نظرات ارزشمند شما:

برای ارسال نظر ابتدا باید وارد سایت شوید

  • سلام استاد وقت بخیر
    موقع نصب laravel passport با این خطا مواجه می شم

    Problem 1
    
    - laravel/passport[v11.8.0, ..., v11.8.4] require league/oauth2-server ^8.2 -> satisfiable by league/oauth2-server[8.2.0, ..., 8.5.1].
    - laravel/passport[v11.8.5, ..., v11.8.7] require lcobucci/jwt ^4.3|^5.0 -> satisfiable by lcobucci/jwt[4.3.0, 5.0.0].
    - league/oauth2-server[8.2.0, ..., 8.5.1] require psr/http-message ^1.0.1 -> found psr/http-message[1.0.1, 1.1]
    but the package is fixed to 2.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
    - lcobucci/jwt[4.3.0, 5.0.0] require ext-sodium * -> it is missing from your system. Install or enable PHP's sodium extension.
    - Root composer.json requires laravel/passport ^11.8 -> satisfiable by laravel/passport[v11.8.0, ..., v11.8.7].

    To enable extensions, verify that they are enabled in your .ini files:
    - C:\wamp\bin\php\php8.1.0\php.ini
    You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.
    Alternatively, you can run Composer with `--ignore-platform-req=ext-sodium` to temporarily ignore these required extensions.

    Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
    You can also try re-running composer require with an explicit version constraint, e.g. "composer require laravel/passport:*" to figure out if any version is installable, or "composer require laravel/passport:^2.1" if you know which
    you need.

    چند ورژن دیگه هم نصب کردم همه خطا میدن!

    • سلام وقت بخیر.
      روی آخرین ورژن php یعنی 8.2 و لاراول یعنی 10 تست کنید، ببینید مشکل برطرف میشه

  • سلام استاد چند وقتی است نصب و کانفیگ laravel passport در لاراول 9 کمی تغیر کرده میشه این تغیرات را هم توضیح بدید که نسخه جدید laravel passport را چگونه در لاراول 9 نصب کنیم
    ممنونم از شما

    • سلام وقت بخیر.
      چشم بررسی میکنم و بعنوان آپدیت به اتنهای این قسمت یا قسمت جدا اضافه و اطلاع رسانی میشه